HP Laserjet P1005 és Linux Mint 18 párosítása

A régi, jól bevált P1005 telepítése Linux alá már évek óta kicsit macerás. Az egyik verzióváltás után az alap foomatic már nem ismerte fel és használta plug’n’play módban, de pár parancssori utasítással helyre lehetett állítani. Aztán ez a módszer is elszállt, de helyette a megfelelő hplip beszerzésével életre lehetett kelteni a nyomtatót.

Aztán amikor beütöttek a 64bites rendszerek, már ez se volt olyan egyértelműen egyszerű folyamat.

A Linux Mint 17.3 alatt még sikerült a dolog egy leírás alapján, de amikor ráfrissítettem a Mint 18-ra, azonnal elszállt megint minden. A 17.3 alatt bevált leírás rögtön az elején jelezte, hogy a 18-cal nem kompatibilis, majd szépen a függőségek ellenőrzésekor el is hasalt, mondván, hogy nem találja a “libtool”-t, ami azért volt érdekes, mert fent volt a rendszerben… :/ Végül sikerült rájönnöm, hogy egy

sudo apt-get install libtool*

megoldja a dolgot, feltesz még pár csomagot, és a hplip telepítő végre képes tovább futni.

A megoldás lépései tehát ezek:

  • sudo apt-get install libtool*
  • ha ez megvan, akkor szedd le a legújabb hplipet innen: http://prdownloads.sourceforge.net/hplip/hplip-3.16.5.run
  • menj a letöltésekhez, ahova a hplipet letöltötted
  • sudo chmod +x hplip*
  • ./ hplip*run (a csillag helyére beírhatod a letöltött verzió számát)
  • olvasd el gondosan és válaszolgass értelemszerűen a telepítő kérdéseire (ne lépj ki a telepítőből, válaszd az automata telepítést stb)
  • a megfelelő kérdésnél válaszd a grafikus telepítést
  • kövesd a grafikus telepítő utasításait. Ha mindent jól csinálsz, akkor a végére a tálca értesítési területén megjelenik a HP ikon, és felajánlja a tesztoldal nyomtatási lehetőségét is.
Címke .Könyvjelzőkhöz Közvetlen link.

A hozzászólások jelenleg ezen a részen nincs engedélyezve.